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1 Product Overview

1.1 Products

The PN3 series of Integrated I/O modules
with PROFINET industrial Ethernet bus interface
is a PROFINET slave device with standard IO
architecture, which is compatible with PROFINET
networks from multiple vendors, providing users
with multiple options for high-speed data
acquisition, optimized system configuration,
simplified field wiring, and improved system
reliability.

1.2 Product Characteristics

⚫ Input Compatibility Function
Digital input signals compatible with NPN and PNP

⚫ Ultra-thin
Only 35 mm in height

⚫ Quick
Based on high performance communication chips

⚫ Easy diagnosis
Innovative channel indicator design, close to the channel, channel status at a glance, easy to detect and
maintain

⚫ Easy configuration
Simple configuration and support for all major PROFINET masters.

 Ease of use assembly line
DIN 35 mm standard rail mounting
Adopts screw-fixed terminals for stable and fast wiring.
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2 Naming Rules

2.1 Naming

Serial
number

Meaning Description of values

(1) Bus protocol PN: PROFINET protocol abbreviation
(2) Product

Series
3: Integrated I/O

(3) I/O Type Default: Digital
(4) Input

Signal
Points

16: 16 channel inputs 32: 32-channel input 00: 0 channel input

(5) Number of
output signal
points

16: 16-channel output 32: 32-channel output 00: 0 channel output

(6) Signal Type A: NPN B:PNP Default: NPN & PNP
compatible
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2.2 Model List

Model number Product Description

PN3-1616A 16-channel Digital Input/Output module, NPN type
PN3-0032A 32-Channel Digital Output Module, NPN Type

PN3-3200 32-Channel Digital Input Module, NPN & PNP Compatible
PN3-1616B 16-channel Digital Input/Output module, PNP type
PN3-0032B 32-Channel Digital Output Module, PNP Type
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3 Product Parameters

3.1 Common parameter

Interface parameter

Bus protocol PROFINET
Number of I/O
stations

According to themaster

Data
transmission
medium

UTP or STP (STP recommended) for Category 5 and above

Transmission
distance

≤100 m (station to station)

Transmission rate 100 Mbps
Bus interface 2×RJ45
Technical Parameters

Configuration Through the master
Power supply 24 VDC (18V~36V)
Electrical isolation 500 VAC
Weights 170 g
Sizes 100 x 96 x 35 mm
Operating
temperature

-10℃~+60℃

Storage temperature -20℃~+75℃
Relative humidity 95%, non-condensing
Protection class IP20
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3.2 Digital parameter

Digital input

Rated voltage 24 VDC (18V~30V)
Number of signal points 16, 32
Signal Type NPN/PNP
"0" signal voltage
(PNP)

-3~+3 V

"1" signal voltage
(PNP)

15~30 V

"0" signal voltage
(NPN)

15~30 V

"1" signal voltage
(NPN)

-3~+3 V

Input Filtering Default 3 ms, configurable
Input Current 4 mA
Isolation method Optocoupler Isolation
Isolated Withstand Voltage 500 VAC
Channel Indicator Lights Green LEDs
Digital output

Rated voltage 24 VDC (18V~30V)
Number of signal points 16, 32
Signal Type NPN/PNP
Load Type Resistive loads, inductive loads
Single channel rated
current

Max: 500 mA

Common terminal current Max: 10 A
Port protection Overcurrent protection
Isolation method Optocoupler Isolation
Isolated Withstand Voltage 500 VAC
Channel Indicator Lights Green LEDs
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Name and function description of each part of the product

4 Panel
4.1 Product mix

Serial
number

Name(of a thing) Clarification

① Terminal Dust Cover Can be opened directly
② System identification,

indicator lights
Indicates power, module operation and network port status

(iii) Module identification Labeling product model, channel type
➃ Guideway slot For DIN 35 mm rail fixing
⑤ Bus interface 2×RJ45

(vi) Channel type identification
DI Digital Input
DO Digital Output

(vii) Channel indicators, signs Indicates the corresponding channel signal status
Ⓑ Wiring terminal Screw-in terminal blocks
⑨ Snap Fixed guide clips
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4.2 Indicator light function

Name(ofa
thing)

Markings Color Stateof
affairs

State Description

Power indicator P Green ON Power supply is normal

OFF The product is not powered up or the power supply is
abnormal

Network
Indicator IN

L/A1 Green ON Establish a network connection

Flash Network connection with data interaction

OFF No data interaction or exception

Network
indicator OUT

L/A2 Green ON Establish a network connection

Flash Network connection with data interaction

OFF No data interaction or exception

Operation status
indicator
RUN

R Green ON Module is functioning properly

OFF Abnormal module operation
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Network Alarm
Indicator

BF Red ON Internet connection anomaly

OFF The network connection is working.

SystemAlarm
Indicator

SF Red ON The system is working abnormally

OFF System running normally or not powered up

Input Channel
Status Indicator
signal light

00 to 1F Green ON Module channels have signal inputs

OFF No signal input or abnormal signal input on module
channel

Output Channel
Status Indicator
signal light

00 to 1F Green ON Module channels have signal outputs

OFF No signal output or abnormal signal output from
module channels
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4.3 Model number and information labeling

Name(ofa
thing)

Markings Description

Module
Model

PN3-1616A Module Model

Bus
protocol

PROFINET Bus protocol

Channel
Type

16DI+16DO 16 digital inputs + 16 digital outputs
IN: TYP.4mA (DC24V); NPN/PNP Input Channel: Current 4mA, Voltage 24V, NPN &

PNP compatible
OUT: Max.0.5A/Ch; NPN Output channel: single channel current max.

0.5A, NPN type
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PN3-0032A/PN3-0032B

4.4 Terminal Identification

PN3-1616A/PN3-1616B

Markings Description

S24V
System Side Power Supply

S0V
PE Reserve
COM Input Common
DI Digital Input Channels
00~0F Input channel
F24V

Field Side Power Supply
F0V
NC Empty terminal
DO Digital output channels
10~1F Output channel

Note: PN3-1616A/PN3-1616B terminal blocks are
labeled the same.

Markings Description

S24V
System Side Power Supply

S0V
PE Reserve
NC Empty terminal
DOa

Digital output channels
DOb
00~0F

Output channel
10~1F
F24V

Field Side Power Supply
F0V

Note: PN3-0032A/PN3-0032B Wiring terminals are
labeled the same.
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s

Markings Description
S24V

System Side Power Supply
S0V
PE Reserve
COMA

Input Common
COMB
DIa

Digital Input Channels
DIb
00~0F

Input channel
10~1F
NC Empty terminal

PN3-3200
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Precautions for installation\dismantling

Mounting direction

5 Installation and

disassembly

⚫ Ensure that the cabinet is well ventilated (e.g., the cabinet is fitted with an exhaust fan).

⚫ Do not install this equipment next to or above equipment that may cause overheating.

⚫ Always install the module vertically and ensure sufficient spacing between the module and the surrounding
equipment.

⚫ Be sure to disconnect the power supply when installing/disassembling.

To maintain proper heat dissipation from the module, be sure to install the module vertically to ensure

smooth airflow inside the module.
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dismountin

Outline specifications (in mm)

Module protection class is IP20, need to be installed in the box or cabinet, installation, module
and other modules or heat generating equipment, module up and down and other equipment or
wiring slot, please follow the minimum spacing shown in the following figure (unit: mm).

5.1 External Dimensions

Minimum distance
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5.2 Installation and disassembly

Mounting Move

Push the snap on the
bottom of the
module outward, as
shown in Fig. ①, and
then push the snap
to the position as
shown in Fig. ②, and
then hear a "click"
sound.

① ②

Align the upper edge
of the module snap
with the upper edge
of the rail and place
the module into the
rail as shown in
Figure③.

③

The module placement is shown in Figure 4.

➃

Copyright © Nanjing Solid
Electronic Technology Co.
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Dismantle Move

Push the snap in the
direction of the rail
and hear the ringing
sound to complete
the module
installation, as
shown in Figure ⑤.

⑤

Insert the flat head
into the s n a p and
apply pressure in the
direction of the
module.
(Rattle heard.)
Remove themodule
by reversing the
p r o c e d u r e for
installing the module,
as shown in Figure⑥.

⑥
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Power supply wiring precautions

Wiring Tool Requirements

6 Wiring
6.1 Wiring terminal

Wiring terminal

Power and signal line
terminals

Extremity 2×20 P
Wire diameter 24~17 AWG 0 .2~1.0 mm²

Bus interface 2×RJ45 UTP or STP (STP recommended) for Category 5 and above

6.2 Wiring instructions and requirements

⚫ The module system-side power supply and the field-side power supply are configured and used separately, so
do not mix them.

⚫ PEmust be reliably grounded.

The terminals are designedwith set screws, and

the installation and removal of cables can be

operated with a one-piece screwdriver

(specification: ≤2mm).
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g

insulated terminals, the reference specifications are shown in the

Wiring Method

Recommended stripping length 6 mm.

For single stranded hardwires, after stripping the corresponding

length of wire, insert the wire into the terminal while tightening

the screw with a screwdriver.

Multi-stranded flexible wires, stripping the corresponding length

of the wire, supporting the use of the corresponding standard

specifications of the cold compression terminals (tube-type

Tube Insulation End Specification Sheet

Wire inserted into the terminal at the same time with a
screw driver to tighten the screws.

Model number Cross-sectional area of
conductor mm²

Tube insulated terminal L ≥ 6 mm in length

E0306 0.3
E0506

0.5
E0508
E7506

0.75
E7508
E1006

1.0
E1008

⚫ Signal terminal wiring requirements

Press the signal cable into the terminal block with reference to the corresponding I/O module wiring diagram
and wiring method.

⚫ Bus Wiring Requirements

⮚ Utilizes standard RJ45 network interface with standard crystal connectors

⮚ The length of the cable between the devices must not exceed 100m.

17

Stripped Wire Length Requirements

Pin
number

Code

1 TD+
2 TD-
3 RD+
4 -
5 -
6 RD-
7 -
8 -
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6.3 I/O module wiring diagram

6.3.1 PN3-1616A

Gauge Orientations Signal Name Gauge Orientations Signal Name

1 Input PE 11 Input S24V
2 Input COM 12 Input S0V
3 Input X00 13 Input X08
4 Input X01 14 Input X09
5 Input X02 15 Input X0A
6 Input X03 16 Input X0B
7 Input X04 17 Input X0C
8 Input X05 18 Input X0D
9 Input X06 19 Input X0E
10 Input X07 20 Input X0F

Gauge orientations Signal Name Gauge Orientations Signal Name

1 Input F24V 11 Input F0V
2 Input F0V 12 None NC
3 Output Y00 13 Output Y08
4 Output Y01 14 Output Y09
5 Output Y02 15 Output Y0A
6 Output Y03 16 Output Y0B
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7 Output Y04 17 Output Y0C
8 Output Y05 18 Output Y0D
9 Output Y06 19 Output Y0E
10 Output Y07 20 Output Y0F

Note: The module terminal ports are rated for 8A, when the total output load current of the module channels
exceeds 8A, both F0V ports need to be wired.

6.3.2 PN3-0032A

Gauge Orientations Signal Name Gauge Orientations Signal Name

1 Input PE 11 Input S24V
2 None NC 12 Input S0V
3 Output Y00 13 Output Y08
4 Output Y01 14 Output Y09
5 Output Y02 15 Output Y0A
6 Output Y03 16 Output Y0B
7 Output Y04 17 Output Y0C
8 Output Y05 18 Output Y0D
9 Output Y06 19 Output Y0E
10 Output Y07 20 Output Y0F

Gauge Orientations Signal Name Gauge Orientations Signal Name

1 Input F24V 11 Input F0V
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2 Input F0V 12 None NC g

3 Output Y10 13 Output Y18
4 Output Y11 14 Output Y19
5 Output Y12 15 Output Y1A
6 Output Y13 16 Output Y1B
7 Output Y14 17 Output Y1C
8 Output Y15 18 Output Y1D
9 Output Y16 19 Output Y1E
10 Output Y17 20 Output Y1F

Note: The module terminal ports are rated for 8A, when the total output load current of the module channels
exceeds 8A, both F0V ports need to be wired.

6.3.3 PN3-3200

Gauge Orientatio
ns

Signal Name Gauge Orientatio
ns

Signal Name

1 Input PE 11 Input S24V

2 Input COMA 12 Input S0V

3 Input X00 13 Input X08

4 Input X01 14 Input X09
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5 Input X02 15 Input X0A g

6 Input X03 16 Input X0B

7 Input X04 17 Input X0C

8 Input X05 18 Input X0D

9 Input X06 19 Input X0E

10 Input X07 20 Input X0F

Gauge Orientatio
Ns

Signal Name Gauge Orientatio
Ns

Signal Name

1 None NC 11 None NC
2 None NC 12 Input COMB

3 Input X10 13 Input X18

4 Input X11 14 Input X19

5 Input X12 15 Input X1A

6 Input X13 16 Input X1B

7 Input X14 17 Input X1C

8 Input X15 18 Input X1D

9 Input X16 19 Input X1E

10 Input X17 20 Input X1F
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6.3.4 PN3-1616B

Gauge Orientations Signal Name Gauge Orientations Signal Name

1 Input PE 11 Input S24V
2 Input COM 12 Input S0V
3 Input X00 13 Input X08
4 Input X01 14 Input X09
5 Input X02 15 Input X0A
6 Input X03 16 Input X0B
7 Input X04 17 Input X0C
8 Input X05 18 Input X0D
9 Input X06 19 Input X0E
10 Input X07 20 Input X0F

Gauge Directional Signal Name Gauge Directional Signal Name

1 Input F24V 11 Input F0V
2 Input F0V 12 None NC
3 Output Y00 13 Output Y08
4 Output Y01 14 Output Y09
5 Output Y02 15 Output Y0A
6 Output Y03 16 Output Y0B
7 Output Y04 17 Output Y0C
8 Output Y05 18 Output Y0D
9 Output Y06 19 Output Y0E
10 Output Y07 20 Output Y0F

Note: The module terminal ports are rated for 8A, when the total output load current of the module channels
exceeds 8A, both F0V ports need to be wired.
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6.3.5 PN3-0032B

Gauge Orientations Signal Name Gauge Orientations Signal Name

1 Input PE 11 Input S24V
2 None NC 12 Input S0V
3 Output Y00 13 Output Y08
4 Output Y01 14 Output Y09
5 Output Y02 15 Output Y0A
6 Output Y03 16 Output Y0B
7 Output Y04 17 Output Y0C
8 Output Y05 18 Output Y0D
9 Output Y06 19 Output Y0E
10 Output Y07 20 Output Y0F

Gauge Orientations Signal Name Gauge Orientations Signal Name

1 Input F24V 11 Input F0V
2 Input F0V 12 None NC
3 Output Y10 13 Output Y18
4 Output Y11 14 Output Y19
5 Output Y12 15 Output Y1A
6 Output Y13 16 Output Y1B
7 Output Y14 17 Output Y1C
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8 Output Y15 18 Output Y1D
9 Output Y16 19 Output Y1E
10 Output Y17 20 Output Y1F

Note: The module terminal ports are rated for 8A, when the total output load current of the module channels
exceeds 8A, both F0V ports need to be wired.
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7 Use
7.1 Parameter description

7.1.1 Digital Input Filter Period Setting
Digital input filtering prevents the program from responding to unexpected rapid changes in the input

signal that may be generated by switch contact jumps or electrical noise. For modules with input channels,
the filtering time of the digital inputs can be selected via the Filter Period parameter setting, which filters
out spurious waves within the set time; the channels are not individually configurable.

For example, an input filter time of 3 ms means that a single signal change from "0" to "1" or
from "1" to "0" lasts 3 ms before it can be detected. "A single high pulse or low pulse
shorter than 3 ms will not be detected.

7.1.2 Output signal clear/hold function
Clear/Hold function is for modules with output channels, this function can configure the
module output action in the bus abnormal state. Clear output: When communication is
disconnected, the output channel of the module will automatically clear the output.
Hold Outputs: The module output channels keep outputs when communication is disconnected.

This manual takes TIA Portal V17 as an example to introduce the parameter configuration method, and the
specific steps are described in Chapter 7.2.1 Parameter Settings.
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7.2 Configuration Module Applications

7.2.1 Application in TIA Portal V17 Software Environment

1. Preparation

⚫ hardware environment

⮚ Module Model PN3-1616A

⮚ One computer with TIA Portal V17 software pre-installed

⮚ Shielded cables for PROFINET

⮚ One Siemens PLC, this description takes Siemens S7-1200 CPU1214C DC/DC/DC as an example

⮚ One switching power supply

⮚ Module mounting rails and rail mounts

⮚ Device Configuration Files

Configuration file access: https://www.solidotech.com/documents/configfile
⚫ Hardware configuration and wiring

Follow "5 Installation and Disassembly" and "6 Wiring".

2. New construction

a. Open TIA Portal V17 software, click "Create New Project", enter the information and click "Create" button,
as shown below.

◆ Item name: customizable, can be left as default.
◆ Path: the project keeps the path, which can be left as default.
◆ Version: can be left as default.
◆ AUTHOR: The default can be maintained.
◆ Note: Customizable, may not be filled in.

https://www.solidotech.com/documents/configfile
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3、Add PLC controller

a. Click Configure Devices, as shown in the following figure.

b. Click "Add New Device", select the PLC model you are currently using, and click "Add" as shown below.
After adding, you can view the
The PLC has been added to the device navigation tree on the left.
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4. Scanning for connected devices

a. Click "Online Access -> Update Accessible Devices" in the left navigation tree as shown below.

b. When the update is complete, the connected slave devices are displayed, as shown in the following figure.

The IP address of the computer must be in the same network segment as the PLC, if not, change the IP
address of the computer and repeat the above steps.
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c. Double-click "Online and Diagnostics" under Slave Devices in the left navigation tree, and
you can assign the IP address and configuration name of the current slave under the
"Function" menu. Click "Assign IP Address", fill in "Subnet Mask", then "IP Address", and
click "Assign IP Address" at the bottom. Click "Assign IP Address" at the bottom of the
screen, as shown in the following figure.

d. Click "Assign PROFINET Device Name", fill in "PROFINET Device Name", and click "Assign Name" as

shown below.
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5. Add GSD configuration file
a. In the menu bar, select "Options -> Manage General Station Description File (GSDML)

(D)".
b. Click Source Path to select the folder where the GSD files are stored.
c. Check if the status of the GSD file you want to add is "Not yet installed", click the "Install"

button if it is not installed, or click "Cancel" if it is already installed to skip the installation
step.

6. Add slave devices

a. Double-click on "Devices and Networks" in the left navigation tree.
b. Click the "Hardware Catalog" vertical button on the right, the catalog is displayed as shown below.
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c. Enter "PN3-1616A" in the search box of the hardware catalog to search for the module, after
the search is completed, drag or double-click "PN3-1616A" to the "Network View", as shown in
the following figure. As shown in the figure below. If you want to connect more than one module,
you can add modules according to the actual topology under "Hardware Catalog" on the right side.

d. Click "Unassigned (blue font)" on the slave device and select "PLC_1.PROFINET Interface_1" as shown below.
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e. When the connection is complete, it is shown in the following figure.

f. Click on the device name to rename the device, as shown in the following figure.

g. Click "Device View" to enter the device overview, you can see the topology configuration
information, including the I/O address automatically assigned by the system, the I/O address
can be changed by yourself, as shown in the following figure.
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7. Distribution of equipment names

a. Switch to "Network View", right-click on the cable connecting the PLC and PN3, and select "Assign Device

Name" as shown in the following figure.

b. The Assign PROFINET Device Name pop-up window appears as shown below.

Check to see if the MAC address on the module silkscreen is the same as the MAC address of the assigned
device name.

◆ PROFINET Device Name: Name set in "Assign PROFINET Device Name".
◆ Type of PG/PC interface: PN/IE.
◆ PG/PC interface: the actual network adapter used.
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c. Select the slave device in turn, click Update List, and click Assign Name. Check whether the
status of the node is "OK" in "Accessible nodes in the network", as shown in the following
figure.

d. Click Close.

8、Download the configuration structure

a. In Network View, check PLC.
b. Click the button in the menu bar to download the current configuration to the PLC.
c. In the "Extended Download to Device" window that pops up, configure the settings as shown below.
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d. Click the "Start Search" button as shown below.

e. Click on "Download".
f. Select "Continue without synchronization" as shown below.
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g. Select "Stop All".

h. Click Load.
i. Click Finish.
j. Power the unit back up.

9. Communication connection

a. Click the button, and then click the "Go Online" button, the icons are all green, that is, the connection

is successful, as shown in the following figure.
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10. Parameter setting

a. Open Network View, and in the offline state, right-click on the Module View icon section and click Properties,
as shown in the following figure.

b. In the property page, click "Module Parameters", as shown in the following figure. The
parameters can be configured according to the actual use, after the configuration is completed, re-
download the program to the PLC, the PLC and the module need to be re-powered.
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11. Functional verification

a. Expand the left side of the project navigation, select "Monitor and Force Meter", as shown in the following
figure.

b. Double-click "Add NewMonitor Table", the system adds a new monitor table, as shown in the following figure.
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c. Open the Device View and check the channel Q-address (channel address of the output signal) and the
I-address of the module PN3-1616A in the device overview.

(Channel address of the input signal).
For example, the "Q address" of PN3-1616A module is 2~3, and the "I address" is 2~3, as shown in the figure
below.

d. Fill in the input/output channel address in the address cell of the monitoring table, such

as "QB2", "QB3", "IB2", "IB3", "IB2", "IB2", "IB3", "IB2", "IB3". "Press "Enter", after all the

information is filled in, click the button to monitor the data.

e. Enter "1" in the "Modified Value" cell of QB2, click the button to write, and see the corresponding
channel indicator light up, as shown in the following figure.

f. When a valid voltage is input to input channel 2 of the module, the input value can be monitored in IB1 as
shown below.
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7.2.2 Application in the STEP 7-MicroWIN SMART software environment

1. Preparation

⚫ Hardware environment

⮚ Module Model PN3-1616A

⮚ A PC with pre-installed STEP 7-MicroWIN SMART V2.6 software

⮚ Shielded cables for PROFINET

⮚ One Siemens PLC, this description is based on the Siemens S7-200 SMART for example

⮚ One switching power supply

⮚ Module mounting rails and rail mounts

⮚ Device Configuration Files

Configuration file access: https://www.solidotech.com/documents/configfile
⚫ Hardware configuration and wiring

Follow "5 Installation and Disassembly" and "6 Wiring".

2. Add PLC

a. Open the STEP 7-MicroWIN SMART software.
b. Double-click the button on the left navigation tree to bring up the "System

Block" window, select the CPUmodel corresponding to the PLC, and click the "OK" button, as
shown in the following figure.

https://www.solidotech.com/documents/configfile
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c. Click the button in the left navigation tree to bring up the "Communication" window, switch the
communication interface to the one actually used by the PLC, and click "Find CPU" button to locate the
PLC as shown below.

d. Click the "Edit" button in the communication window, the Edit button is switched to the Set
button, the IP address input box is lit, modify the IP address and the IP address o f t h e
computer interface with the same network segment, modification is complete, click the

"Settings" button again, click the "OK" button after the completion of the setup. Click the "OK"
button after the setting is completed, as shown in the following figure. Note: You can only modify
the IP address of the computer's Ethernet interface, and the PLC address can be the same
network segment.
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3. Inputing GSD files

a. Click "File -> GSDML Management" in the menu bar, click the "Browse" button in the GSDML
Management window, and select the GSDML you want to Input.
file, click the "Confirm" button, as shown below.

4. Finding equipment

a. Click "Tools -> Find PROFINET Device" on the menu bar to bring up the Find PROFINET
Device window, switch the communication interface to the interface actually used by the PLC,
and click "Find Device", as shown in the following figure.
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b. Click the "Edit" button to edit the module name, after editing, click the "Settings" button, as shown
below.

5、Organize PROFINET network

a. Click "Tools -> PROFINET" in the menu bar to open the PROFINET Configuration Wizard as shown below.

b. On the PROFINET Configuration Wizard page, select the role of the PLC as "Controller" as shown below.
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c. Click Next to enter the Controller Configuration page, add a device from the device catalog
tree on the right, select PN3-1616A, and click the Add button, as shown in the following figure.

d. Double-click the input box below the device name to enter the device name, which should be the
same as the name set when searching for the device; double-click the input box below the IP
address to enter the IP address, and then click the "Next" button after finishing the input, as
shown in the following figure. If there are other modules in the configuration, you can add and
configure other modules in the same way.

Note: The device name should be the same as the module name, and the IP address should be set in the
same network segment as the PLC.
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e. Click the "Generate" button, the network configuration is complete, as shown in the figure below, you can
see that the starting address of the module's inputs and outputs are all 128.

6. Download program

a. Click the menu bar "File -> Download" button, the download window pops up, click the "Download" button,
as shown in the figure below.



PN3 Series Integrated I/O UserManual 7 Use

47 All rights reserved © Nanjing Solidot Electronic Technology Co., Ltd.

b. When the download window indicates that the download has been successfully completed, click the "Close"
button.

Note: After the download is complete, power the module back up for processing.

7、Functional verification

a. Click "PLC - > RUN" button on the menu bar, a confirmation window will pop up, click "Yes" to confirm, as
shown in the figure below.
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b. Click "Status Chart -> Chart 1" in the left navigation tree, and enter the corresponding
channel address and data format in Chart 1, where you can perform forced output and input
monitoring operations on IO modules.
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c. In the new value input box corresponding to QB128 a n d QB129 in the output line of the status
chart, you can write the output value, for example, if you write "255", the value of all 16 output
channels will be set to 1, and the output channel lamps will light up. If there is a valid voltage
input to the input channel of the module, the input value can be monitored in IB128, as shown in
the following figure.
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8 FAQ
8.1 Device not found when updating accessible devices

1. Confirm that the Boto software is correctly installed.
2. Make sure that no other software is occupying the network adapter used by the Boto software.
3. Confirm that the network cable, network card, and network port are working properly.
4. Verify that the IP address or MAC address does not conflict.

8.2 Load button is grayed out when downloading configuration

1. Verify that there are nomandatory values in the PLC.
2. Confirm that the PLC is stopped.
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